Symptoms
There's a scheduled backup task in Virtuozzo Automator to back up all VEs and remove the old backups afterward.
The servers (the hardware node and the backup node) are registered in VA.
The task fails with:
Operation with the Virtual Machine "srv1.localdomain.com" is finished with errors: Failed to remove old backup: 894fcf78-81fe-4493-bf04-097be7d200ef@{e2eddff0-7025-4871-906a-7020d04cef68}.3.
There is no backup with the ID mentioned in the error message ({e2eddff0-7025-4871-906a-7020d04cef68} in this example) on the backup node for this VE:
[root@node]# ls -lah /vz/backups/\{894fcf78-81fe-4493-bf04-097be7d200ef\}/
total 32K
drwxrwxrwt 4 root root 4.0K Nov 24 19:39 .
drwxrwxrwt. 123 root root 16K Nov 22 17:04 ..
drwxr----- 6 root root 4.0K Nov 27 03:43 {06651a1c-e67d-4712-8389-cd12bd9260c5}
drwxr----- 7 root root 4.0K Nov 23 01:42 {c5b0894f-60b5-41c6-8af3-eef3d8805227}
-rw-r----- 1 root root 239 Nov 27 03:47 .metadata
Cause
Information about backups in VA is not correct and not up-to-date.
Resolution
1. Restart va-agent at the backup node:
[root@backup_node ~]# service va-agent restart
2. Restart va-mn container:
[root@node ~]# prlctl restart va-mn
3. Refresh backup information on the backup node in Virtuozzo Automator.
In Virtuozzo Automator, select the backup node. Go to Backups, and press Refresh Backups to start reloading backup information. Progress will be shown in VA -> Management -> Task log.